找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 13818|回复: 0

Mysql ibdata丢失或损坏如何通过frm&ibd恢复数据

[复制链接]
发表于 2015-9-30 09:29:45 | 显示全部楼层 |阅读模式
mysql存储在磁盘中,各种天灾人祸都会导致数据丢失。大公司的时候我们常常需要做好数据冷热备,对于小公司来说要做好所有数据备份需要支出大量的成本,很多公司也是不现实的。万一还没有做好备份,数据被误删除了,或者ibdata损坏了怎么办呢?别担心,只要有部分的frm、ibd存在就可以恢复部分数据。" D* M9 i, d! r# A% Y3 P) v) Z
注意:& m# W+ y" S" }. w+ p9 v
一、这个是对innodb的数据恢复。myisam不需要这么麻烦,只要数据文件存在直接复制过去就可以。1 j) x1 W7 u4 b) C+ R4 h
二、大家的mysql数据库必须是按表存放数据的,默认不是,但是大家生产肯定是按分表设置的吧,如果不是,不好意思,这个方法不能恢复你的数据。my.ini的设置为 innodb_file_per_table = 1。还有就是ibd文件和frm文件不能有损坏,frm表结构如果损坏如果你记得表结构还能恢复,如果ibd损坏就彻底没办法了。; u% Y, `  ]! ~+ a  D/ U" i

5 P: [; T7 ^; L$ w1、找回表结构,如果表结构没有丢失直接到下一步
8 k5 `2 B4 b; f$ R2 ]      a、先创建一个数据库,这个数据库必须是没有表和任何操作的。
' N# w2 F  Q7 L9 \$ E  J4 J, G      b、创建一个表结构,和要恢复的表名是一样的。表里的字段无所谓。一定要是innodb引擎的。CREATE TABLE `weibo_qq0`(  `weiboid` bigint(20)) ENGINE=InnoDB DEFAULT CHARSET=utf8;; F) H( E0 O% W" D* z# A
      c、关闭mysql, service mysqld stop;- w8 b# M3 j4 V
      d、用需要恢复的frm文件覆盖刚新建的frm文件;  0 S6 C' f' v# |: k  i! h# |
      e、修改my.ini 里  innodb_force_recovery=1 , 如果不成修改为 2,3,4,5,6。
8 X4 D" X" T+ u8 T2 E/ Q      f、 启动mysql,service mysqld start;show create table weibo_qq0 就能够看到表结构信息了。
4 H: M: q8 N) W* o
4 Y. K9 i* t2 P$ i) A: U2、找回数据。记得上面把 innodb_force_recovery改掉了,需要注释掉,不然恢复模式不好操作。 这里有个关键的问题,就是innodb里的任何数据操作都是一个日志的记录点。也就是如果我们需要数据恢复,必须把之前的表的数据的日志记录点添加到一致。
/ ]# a* u0 O1 j. r, P      a、建立一个数据库,根据上面导出的创建表的sql执行创建表。
; Q$ @* M& x+ H6 e2 T      b、找到记录点。先要把当前数据库的表空间废弃掉,使当前ibd的数据文件和frm分离。  ALTER TABLE weibo_qq0 DISCARD TABLESPACE;5 B( v  \' ?5 w' w
      c、把之前要恢复的 .ibd文件复制到新的表结构文件夹下。 使当前的ibd 和frm发生关系。ALTER TABLE weibo_qq0  IMPORT TABLESPACE; 结果不出意外肯定会报错。就和我们开展数据开始说的那样,数据记录点不一致。我们看看之前ibd记录的点在什么位置。开始执行 import tablespace,报错  ERROR 1030 (HY000): Got error -1 from storage engine。找到mysql的错误日志,InnoDB: Error: tablespace id in file '.\test\weibo_qq0.ibd' is 112, but in the InnoDB  InnoDB: data dictionary it is 1.  因为  weibo_qq0 之前的记录点在112,当前的表只创建一次,所以记录点是1.1 C6 f6 f% i6 |* N) W; K" I# o
      d、那怎么从1记录到112。for ($1=1; $i<=111; $1++) {CREATE TABLE t# (id int) ENGINE=InnoDB;}  也许很奇怪,为什么是循环111,不是112。因为在a执行创建表结构的时候已经记录增加了一次。
. [  d3 K: X$ Q# M3 ?/ o$ `7 d      e、修改表结构 alter table weibo_qq0  discard tablespace;使当前的表结构和ibd脱离关系。复制.ibd到当前的目录结构。' ~) m! L& C" S0 c1 T
      f、使原来数据的ibd和当前frm建立关系。 ALTER TABLE product IMPORT TABLESPACE; 这个时候没有错误,说明已经建立好了。但是查询数据还是查不出来。6 M5 C) Q1 ?! \! N: |4 w
      g、相比这里大家已经知道为什么了,这个模式也不是说改了数据库就可以在生产环境使用。更改 innodb_force_recovery=1 , 如果不成修改为 2,3,4,5,6。直到可以 查询出数据为止,然后dump出来。数据就备份出来了。
' H; N* ]# l" L/ }- \1 {      h、把所有数据导出后,在新的数据库导入。所有数据就生成了。1 X( G3 v1 a: z4 {' d
5 X; {5 F/ N, y0 j' D7 d
      扩展问题,很多时候我们是分表表结构怎么批量操作,提高速度呢。用循环!循环把表的空间废弃掉。' j" R( J5 m+ N: O" z
for i in `seq 0 111`; do mysql -uroot -P33061 -h127.0.0.1 -Dtestdd  -e "CREATE TABLE inv_crawl_weibo_qq$i (id bigint(20) NOT NULL AUTO_INCREMENT,PRIMARY KEY (id)) ENGINE=innodb "; done# \7 e: g+ e$ o& {
ALTER TABLE  inv_crawl_weibo_qq0  DISCARD TABLESPACE;
. P0 {) u$ J) G从备份数据把ibd复制cp到dd数据库下,注意复制过来的文件权限。
, u. p6 P8 H5 S9 \. w2 h循环导入表空间。
! j2 B: j( ?7 v6 h. IALTER TABLE inv_crawl_weibo_qq0   IMPORT TABLESPACE;4 Q) F7 a7 l' s" q
没有报错就导入成功了
( Y  E' Q# D; ?  h/ x/ N* N" c
1 A" o% ?7 s- f' u, ?! x本文来自:it165.net 次元立方网3 s* D* z: e8 F
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|第一站论坛 ( 蜀ICP备06004864号-6 )

GMT+8, 2026-10-5 01:44 , Processed in 0.068527 second(s), 22 queries .

Powered by Discuz! X3.5

© 2001-2026 Discuz! Team.

快速回复 返回顶部 返回列表